Many licensed and some cost-free script-driven applications have encoded code, which is not human readable. The idea behind this is to prevent the reverse engineering as well as the not authorized usage of such apps. One of the most popular encryption software instruments used for this specific purpose is named Zend Guard and it is popular because it can be used to alter any type of PHP 4 or PHP 5 code. The only method for the protected files to work effectively on a web server subsequently is when another tool called Zend Optimizer is available. When you want to use any paid web software that requires Zend Optimizer, you should make sure that it's installed on the server where you will host your website. Furthermore, sites that need the tool will perform better due to the fact that their code is already precompiled and optimized, and therefore it is executed quicker.
Zend Optimizer in Shared Hosting
Zend Optimizer comes with all servers that are a part of our cutting-edge cloud website hosting platform. No matter which shared hosting you select, you can use the instrument so that any kind of script app that requires it will function perfectly as part of your account. Using a handy instrument in the Advanced area of the Hepsia Control Panel which is provided with all the website hosting accounts, you can activate and deactivate many different settings with a button. Zend Optimizer will be one of these, so even if this is your first hosting account ever, you won't have any issues. In the same area you can also pick the PHP version for your account - 4 and numerous versions of 5, so any time you change to one that you have not used yet, you can enable Zend Optimizer for it with a single click. Since our platform allows you to employ several PHP versions simultaneously, more advanced users can enable the tool for a particular website with a php.ini file in a specific domain folder as well.
Zend Optimizer in Semi-dedicated Servers
Zend Optimizer is installed on all servers that comprise our cluster web hosting platform, so you are able to use it for all of your script-driven applications with all of our semi-dedicated server plans. It'll be available all the time even if you change the PHP release for your account because our feature-rich platform will allow you to choose between PHP 4, 5.2, 5.3, 5.4 and 5.5. Both changing the version and activating Zend Optimizer for the new one takes just a couple of clicks in the PHP Configuration section of the Hepsia website hosting Control Panel that is used to manage the semi-dedicated accounts. What's more, you may also employ a different version of PHP and enable or disable Zend for every single site that you host in your account. You can do this by using a php.ini file in a domain folder with several lines of code inside it. If you don't have previous experience and you are not sure how to do that, our 24/7 support will assist.