PHP is among the most commonly used dynamic programming languages. It is rather popular since it is free software, which you can use to set up responsive sites like social networks, shopping portals or e-teaching portals rather than static HTML-based sites. A PHP module should be available on the server where a PHP website is hosted so that its PHP code can be ‘decoded’. As there are no license charges for this type of module and the language itself provides incalculable options for the web apps that you create, there’re hundreds of millions of PHP-driven websites. In addition, there are a huge number of open-source PHP-based scripts, which you can use for your websites without needing to possess any coding knowledge. Considering the fact that there are different versions of PHP, you ought to check if the same version that you used whilst developing your site is present on the web server too.
PHP 4 and PHP 5 Support in Shared Hosting
We have made a conscious decision not to restrict our present and potential customers from selecting the PHP version that will be used by their sites, so in case you order a shared hosting plan from our company, you’ll be able to pick between versions 4, 5.2, 5.3, 5.4 and 5.5, not only for the hosting account itself, but also for each single domain name that you host. This can be accomplished with only one click from our in-house built Hepsia Control Panel via which all accounts are managed, so you will not need any technical or programming skills. You’ll be able to run websites based on both new and old PHP scripts without any hassles, so if you want to drop your current provider and switch over to us, you can rest assured that all the websites that you’ve built through the years will continue to run correctly.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
Even in case your websites were created with an older version of PHP, you’ll be able to host them in a semi-dedicated server account from us, since we support multiple versions running simultaneously on our servers and each of them can be enabled for your account with no more than one click via our in-house created Hepsia hosting Control Panel. In addition to the latest PHP 5.4 and PHP 5.5, we also offer 5.2, 5.3 and the older PHP 4, which has already been dropped by most web hosting vendors, but we strongly trust that you should not be compelled to modify a site that took several years to create, as older script language syntax doesn’t necessarily mean security gaps. On the contrary, a correctly maintained website using PHP 4 can be more secure than an unmaintained one using PHP 5. For the sake of your convenience, we will also offer you the possibility to set a different PHP version for each single website within your account.